Packages Json

Packages Used

1
{
2
"name": "enatega-rider-app",
3
"version": "2.0.0",
4
"main": "node_modules/expo/AppEntry.js",
5
"scripts": {
6
"start": "expo start",
7
"android": "expo start --android",
8
"ios": "expo start --ios",
9
"eject": "expo eject",
10
"postinstall": "patch-package",
11
"format": "prettier --write '**/*.js'",
12
"lint:fix": "eslint . --ext .js --fix"
13
},
14
"husky": {
15
"hooks": {
16
"pre-commit": "lint-staged"
17
}
18
},
19
"lint-staged": {
20
"*.js": [
21
"npm run format",
22
"npm run lint:fix"
23
]
24
},
25
"dependencies": {
26
"@apollo/react-hooks": "^3.1.5",
27
"@expo/vector-icons": "^12.0.0",
28
"@react-native-async-storage/async-storage": "^1.13.2",
29
"@react-native-community/masked-view": "0.1.10",
30
"@react-navigation/bottom-tabs": "^5.7.2",
31
"@react-navigation/drawer": "^5.8.6",
32
"@react-navigation/native": "^5.7.1",
33
"@react-navigation/stack": "^5.7.1",
34
"@types/react": "~16.9.35",
35
"apollo-cache-inmemory": "^1.6.6",
36
"apollo-client": "^2.6.10",
37
"apollo-link": "^1.2.14",
38
"apollo-link-http": "^1.5.17",
39
"apollo-link-state": "^0.4.2",
40
"apollo-link-ws": "^1.0.20",
41
"expo": "^40.0.0",
42
"expo-constants": "~9.3.3",
43
"expo-font": "~8.4.0",
44
"expo-localization": "~9.1.0",
45
"expo-location": "~10.0.0",
46
"expo-notifications": "~0.8.2",
47
"expo-permissions": "~10.0.0",
48
"expo-splash-screen": "~0.8.1",
49
"expo-task-manager": "~8.6.0",
50
"graphql": "^14.7.0",
51
"graphql-tag": "^2.10.4",
52
"i18n-js": "^3.7.1",
53
"patch-package": "^6.2.2",
54
"postinstall-postinstall": "^2.1.0",
55
"react": "16.13.1",
56
"react-dom": "16.13.1",
57
"react-native": "https://github.com/expo/react-native/archive/sdk-40.0.1.tar.gz",
58
"react-native-animatable": "^1.3.3",
59
"react-native-flash-message": "^0.1.21",
60
"react-native-gesture-handler": "~1.8.0",
61
"react-native-maps": "0.27.1",
62
"react-native-material-textfield": "^0.16.1",
63
"react-native-modal": "^11.5.6",
64
"react-native-reanimated": "~1.13.0",
65
"react-native-safe-area-context": "3.1.9",
66
"react-native-screens": "~2.15.0",
67
"react-native-webview": "11.0.0",
68
"subscriptions-transport-ws": "^0.9.17",
69
"expo-updates": "~0.4.1"
70
},
71
"devDependencies": {
72
"babel-preset-expo": "8.3.0",
73
"eslint": "^7.1.0",
74
"eslint-config-standard": "^14.1.1",
75
"eslint-plugin-import": "^2.20.2",
76
"eslint-plugin-node": "^11.1.0",
77
"eslint-plugin-promise": "^4.2.1",
78
"eslint-plugin-react": "^7.20.0",
79
"eslint-plugin-standard": "^4.0.1",
80
"husky": "^4.2.5",
81
"lint-staged": "^10.2.7",
82
"prettier": "2.0.5",
83
"prettier-config-standard": "^1.0.1"
84
},
85
"private": true
86
}
87
Copied!
Copy link